Featured Slider – images slow to load

Home Forums Troubleshooting Featured Slider – images slow to load

This topic contains 3 replies, has 2 voices, and was last updated by  Sagar Katarnaware 1 month, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #12100

    kellkbra
    Member

    Hello – I just replaced the Pointelle Slider with the Featured Slider on my site’s homepage and I love the new look. I actually don’t want any movement or navigation, I just want to show the featured image & title of the most recent 5 posts.

    I have a great looking slider displaying fine, except that it loads the 5 images slowly and after the rest of the page has loaded. This behavior did not happen with the Pointelle slider.

    I should note that my site is fairly well optimized and images are highly compressed for the web:
    – Premium hosting
    – WP Rocket caching
    – Paid MaxCDN content delivery network
    – Images (all sizes) compressed with EWWW using maximum compression
    – Site scores all “A”‘s on webpagetest.org tests
    – I’m not seeing and JS errors or multiple loads of JS
    – Theme is a premium Genesis child theme, with the “Featured Slider-Recent Posts” widget placed in the theme’s home page widget location

    Major settings for the slider are:
    Skin: default
    Auto-slide off
    Fixed blocks On
    Image controls:
    – Image Source: only “Featured Image”
    Text controls:
    – Content disabled
    – Meta disabled
    Navigation arrows not shown

    Global settings: set “Embed JS files in head” to ON

    Any ideas how to make these images load approx as fast or perhaps before the rest of the images on the page?

    Thanks,
    Kelly

    #12101

    Hello @kellkbra

    Thanks for writing to us.

    Please go to WordPress dashboard => Featured slider => Manage sliders => Find and Edit your slider => Easy builder of slider will appear => Basic Settings tab => No. of Slides => Set 5 and Save changes,

    Now for navigation arrow go to WordPress dashboard => Featured slider => Manage sliders => Find and Edit your slider => Easy builder of slider will appear => Navigation panel => Arrows => Disable switch and Save changes.

    Let me know if it helps.
    Thank you for your patience.

    Best Regards,
    Sagar.

    #12102

    kellkbra
    Member

    Hi Sagar – Thanks for the response.

    I already had these settings configured, and the slider looks exactly like I want it to.

    The issue is the slow loading performance – slider fails to appear until aftermost of the rest of the site loads, and then the images each seem to load one at a time, slowly.

    I never had this problem on this site with the Pointelle slider.

    As I posted originially, my site is overall very well optimized, including the images, so you can’t say my images are large and that is why it takes time to load.

    Do you have any suggestions for getting the slider to perform (load) faster?

    #12109

    Hello @kellkbra

    Thanks for your response.

    For fast loading performance, I would suggest you please use exact size or optimize images in slider. It will help you to increase performance of site.

    Let me know if it helps.
    Thank you for your patience.

    Best Regards,
    Sagar.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.